Inaccessibilty of the plateforms
Incident Report for talkspirit
Resolved
10h00. OHV severs were down. Now talkSpirit is back online.
Posted over 2 years ago. Jan 06, 2017 - 10:00 CET
Investigating
Since 9h20 our service talkSpirit is down. We are investigating. We will send you further notice.
Posted over 2 years ago. Jan 06, 2017 - 09:31 CET