Inaccessibilty of the plateforms
Incident Report for talkspirit
Resolved
Everything seems to be back to normal now.
Posted over 2 years ago. Jan 31, 2017 - 15:06 CET
Investigating
It seems that our provider is having some network instabilities again.
Posted over 2 years ago. Jan 31, 2017 - 14:55 CET